Dependencies

From OpenBlox
Jump to: navigation, search
This page contains changes which are not marked for translation.

Other languages:
English • ‎français

OpenBlox has the folowing optional dependencies:

  • ENet (required for networking)
  • Bullet (required for physics)
  • curl (required for non-resource assets)
  • pugixml (required for serialization/deserialization)
  • Lua (required for scripting)
  • Irrlicht (required for graphics)

These dependencies are not required to compile OpenBlox. To compile OpenBlox Studio, you also need Qt.

The article Building on Windows provides instructions for installing the dependencies and building OpenBlox on Windows.